Dla programistów leniuszków. Travis CI.

Próbowałem dodać sobie do konta Githubowego automatyczne buildy przez serwis Travis CI.


Niestety mimo, że builduje mi się lokalnie przez polecenie rake, to zdalnie lecą błędy:

/home/travis/.rvm/rubies/ruby-1.9.3-p551/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- test/unit/testsuite (LoadError)
 from /home/travis/.rvm/rubies/ruby-1.9.3-p551/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:54:in `require'
 from ./test/all_tests.rb:1:in `<main>'
rake aborted!
Command failed with status (1): [/home/travis/.rvm/rubies/ruby-1.9.3-p551/b...]
/home/travis/build/coola/xp-simulator/Rakefile:4:in `block in <top (required)>'
/home/travis/.rvm/gems/ruby-1.9.3-p551/bin/ruby_executable_hooks:15:in `eval'
/home/travis/.rvm/gems/ruby-1.9.3-p551/bin/ruby_executable_hooks:15:in `<main>'
Tasks: TOP => default => test
(See full trace by running task with --trace)
The command "rake" exited with 1.
Done. Your build exited with 1.


Chyba brak odpowiednich bibliotek, z których korzystam w projekcie. Na przykład ruby-test.

Stworzyłem w katalogu głównym plik .travis.yml, który nadpisze domyślne ustawienia builda.
Spróbuję wymusić, żeby wersja Ruby była taka sama jak wersja, jaką mam na serwerze czyli 2.3.1

language: ruby
rvm:
  - 2.3.1

I rzeczywiście działa :) To nie były biblioteki. Chodziło o wersję języka Ruby. Musi być nowsza, żeby ogarniała nową składnię polecenia require.

Commit do tego TU:

Brak komentarzy:

Prześlij komentarz